Beginning on August 11th around 13:10 UTC until 14:04 UTC, apps in our EU region experienced high request latency and possible connection errors. We sincerely apologize for the problems this caused.
Here is some additional detail about what happened and steps we are taking to mitigate future out…
Resolved
Latency has returned to normal.
Update
We have identified the issue and we are working to put a fix in place
Issue
Requests to the EU region are experiencing an increase in latency. Our Engineers are investigating.