Slow Response Times

Apps 1 hour, 13 minutes
Data 50 minutes
Tools 22 minutes

Activity

  • Resolved

    Network connectivity has been fully restored.

    Posted 14 years ago, Sep 18, 2010 17:58 UTC

  • Update

    Our infrastructure provider is experiencing network outages. They are working on restoring network connectivity.

    Posted 14 years ago, Sep 18, 2010 17:07 UTC

  • Issue

    We're aware of a problem with some slow response times.

    We are currently investigating.

    Posted 14 years ago, Sep 18, 2010 16:45 UTC

Current status