Heroku Status

Current Status and Incident Report

Elevated Error Rates

Production 3h Development 2h12m

Resolved

The Heroku API and dyno infrastructure are now fully online and stable.

We're continuing to recover the remaining affected databases and will be tracking the recovery processes via a new status incident.

Update

The API is now fully functional. Our engineers are continuing to work to recover the remaining affected databases.

Update

We are continuing to restore stability to the underlying affected infrastructure components. The API is in a read-only mode. Some databases are also affected and our engineers are restoring them now.

Update

Git-push deploys have been re-enabled. The API remains in read-only mode.

Update

The Heroku API has been transitioned from maintenance to read-only mode. App unidling has been restored. H99 error rates are falling rapidly, but some apps are still experiencing errors.

Update

Our engineers are continuing efforts to move Heroku components onto working infrastructure. The API and deploys remain disabled.

Update

Heroku API remains in maintenance mode while we attempt to recover from infrastructure issues.

Some running apps are experiencing H99 errors, and apps are not able to unidle currently. Deploys are also temporarily disabled.

We're continuing to replace routing infrastructure to improve performance for apps using A records.

Issue

We have detected a failure of an HTTP router servicing one of our apex domain IP addresses. Apps with apex domains using A records mapped to this IP may experience partial HTTP errors. Engineers are failing over to a backup router and expect to resolve the issue shortly.

Issue

We're experiencing an issue with our infrastructure provider. We've placed our API into maintenance mode while we fix the underlying issues.

Some applications may experience issues launching processes or unidling dynos.

Investigating

The Heroku API is having availability issues. We're investigating.

Running apps are not affected.

← Current Status