Resolved
The performance degradation was due to reaching capacity on the routing mesh. We have added more capacity and are adding additional monitoring to prevent recurrence of the issue.
Issue
We are currently experiencing a general performance degradation across the cloud. We are investigating and working towards a resolution.