Node.js Build Timeout Errors

Tools 1 hour, 0 minutes

Activity

  • Resolved

    Node.js build timeout issues have been resolved. Please note that customers who have pinned to a specific Node.js buildpack release or branch will need to update their version to receive the fix.

    Posted 3 months ago, Nov 20, 2024 21:15 UTC

  • Update

    Customers experiencing build timeouts using Node.js 20 can temporarily workaround the issue by running heroku config:set UV_USE_IO_URING=0.

    Our engineers have identified the issue and are working to fix the problem with node.js builds.

    Posted 3 months ago, Nov 20, 2024 20:42 UTC

  • Issue

    Some customers are encountering issues with Node.js builds, resulting in timeout errors.

    Posted 3 months ago, Nov 20, 2024 20:15 UTC

Current status