DNS propagation delays

US EU

Follow-up Report

Activity

  • Resolved

    Resolved at 19:10 UTC. Related to NS1 outage. https://ns1status.com/incident/541438.

    Posted 9 months ago, May 4, 2024 20:57 UTC

  • Investigating

    DNS propagation delays result in app inaccessibility.

    Posted 9 months ago, May 4, 2024 05:30 UTC

Current status