Resolved
The Heroku build system is working as expected and the incident is now resolved. The impact start time is September 4, 2023 08:55 UTC and the end time is September 5, 2023 05:12 UTC.
Update
Engineers are still collaborating with GitHub to address the ongoing issue. Some Heroku customers are experiencing intermittent failures in auto-deploying apps using Heroku’s GitHub integration. Heroku customers experiencing intermittent auto-deploy failures may also experience failures in Heroku Review Apps. The workaround for manual deploys on Heroku is still suggested. There is no known workaround for failures in Heroku Review Apps. We will keep you posted as we have more details.
Update
Our engineers continue to collaborate with GitHub. GitHub has acknowledged an issue in their system. Customer apps that are auto-deployed using Heroku’s GitHub app are intermittently failing. As a workaround, impacted customers can get source code locally using git clone
from GitHub or use a local working copy. Customers should ensure the heroku
remote is set. If not, the remote can be set with heroku git:remote -a <app name>
. Then, deploy directly to Heroku using git push heroku main
.
Update
Engineers are still actively collaborating with GitHub to address the ongoing issue. We will keep you posted as we have more details.
Issue
Our engineers have identified the issue causing timeouts during the download of tarballs from GitHub in the build process. We are working with GitHub to resolve the issue. We will keep you posted as we have more details.
Investigating
We are investigating reports of build failures for a subset of customers. Impacted Apps will see "Unable to fetch source from GitHub. Please ensure your GitHub connection is valid and that any GitHub security settings are configured to allow Heroku access" error message in build logs. Our engineers are investigating the issue and we will continue to post updates.