Resolved
Our Engineers identified that the issue is due to new features released in a third-party library used in the packaged docker-build-push GitHub action (BuildKit version 0.11). These features are not currently supported by Heroku. However, there is a workaround as documented here: https://help.heroku.com/74S3XXMP/workaround-for-docker-push-error-405-method-not-allowed-using-buildkit-0-11
Update
Our engineers further investigated and have uncovered that Docker pushes from GitHub Actions using https://github.com/docker/build-push-action are failing. To workaround, customers encountering this issue may use "docker push" directly instead of the packaged action: https://devcenter.heroku.com/articles/container-registry-and-runtime#pushing-an-existing-image
Issue
Starting 19/01/2023 we have identified that Docker pushes from GitHub Actions using https://github.com/docker/build-push-action are failing. This does not impact existing deployments. The error "405 Method not allowed" is related to this situation. To workaround, customers encountering this issue may use docker push directly instead of the packaged action: https://devcenter.heroku.com/articles/container-registry-and-runtime#pushing-an-existing-image We are working to resolve this problem as soon as possible.