Resolved
Engineers mitigated the problem.
Issue
Engineers are looking into a subset of Heroku Connect in the Virginia region reporting the Heroku Postgres database being unavailable. Other Heroku Connect in the Virginia region are seeing delayed synchronization.
Heroku Connect in the Virginia region will have experienced delayed synchronization due to networking issues. Some Heroku Connect customers additionally are seeing that their connections are in the DB_UNAVAILABLE state, even though the databases are healthy.