Resolved
This incident is now resolved. The impact start and end times are identified as 2022-07-18 16:35 UTC and 2022-07-18 22:01 UTC
Update
Our engineers are still investigating the issue.
Issue
Heroku Engineering is investigating reports of some customers being unable to access invoices via the dashboard.