Resolved
The issue is now resolved.
Posted 3 years ago, Jun 20, 2022 17:45 UTC
Retroactive
Engineers identified an issue where some customers found their apps were unavailable from 17:30 to 17:45 UTC today. The issue has been resolved.
Posted 3 years ago, Jun 20, 2022 17:30 UTC