Resolved
The issue has been resolved since 00:50 UTC 6th May.
Posted 3 years ago, May 6, 2022 01:34 UTC
Issue
Engineers are looking into reports of errors when opening add-ons pages starting from 21:39 UTC 5th May.
Posted 3 years ago, May 6, 2022 01:19 UTC