Resolved
The Technology team continues to see a positive trend as customers are manually disabling MTLS and re-enable MTLS. An all-clear has been declared, and we will perform a full investigation of the incident, confirming the technical trigger, the underlying cause, and preventive action to avoid a repeat in the future. We apologize for how you and your business may have been affected by this incident.
Update
The Technology team continues their investigation to implement a permanent fix. As mentioned in the previous update, customers are advised to continue to use the workaround. We’ll provide the next update when additional information becomes available.
Update
The Technology team continues their investigation to implement a permanent fix. Until the fix is finalized and rolled out, customers are advised to continue to use the workaround. The investigation is not expected to complete until US hours on April 27. We’ll provide the next update at approximately 13:00 UTC, or sooner if additional information becomes available.
Update
The team is verifying the resolution for this issue and closely monitoring before declaring an all-clear. The temporary workaround of manually disabling MTLS and re-enable MTLS continues to be a viable option for customers.
We’ll provide an update in 2 hours, or sooner if additional information becomes available.
Update
The team is working diligently toward a full resolution of the issue and expect a fix to be implemented within 30 minutes. The temporary workaround of manually disabling MTLS and re-enable MTLS continues to be a viable option for customers. We’ll provide an update in 60 minutes, or sooner if additional information becomes available.
Update
The Technology team are exploring multiple paths to address this issue. The temporary workaround of manually disabling MTLS and re-enable MTLS continues to be a viable option for customers. In addition, the teams have applied a fix for Kafka MTLS, along with a repair script to address the Heroku Streaming Data Connectors to fully mitigate this issue. We’ll provide an update in 60 minutes, or sooner if additional information becomes available.
Update
The Technology team remains engaged to investigate Heroku Streaming Data Connectors data stream issue. The temporary workaround of manually disabling MTLS and re-enable MTLS continues to be a viable option for customers.
We’ll provide an update in 60 minutes, or sooner if additional information becomes available.
Update
The Technology team has engaged additional engineering resources to assist in the investigation. They continue working toward a full resolution for this issue.
We’ll provide an update in 30 minutes, or sooner if additional information becomes available.
Update
The team is working urgently toward a full resolution of the issue. The temporary workaround of manually disabling MTLS and re-enable MTLS continues to be a viable option for customers. We’ll provide an update in 30 minutes, or sooner if additional information becomes available.
Update
The team remains engaged and continues to investigate the issue and analyze data to determine the best path to resolution. As a temporary workaround, customers have found success by manually disabling MTLS and re-enabling MTLS.
We’ll provide an update in 30 minutes, or sooner if additional information becomes available.
Update
At approximately 14:15 UTC on April 26, 2022, our Technology team became aware of a feature disruption affecting customers using MTLS to connect to Heroku Postgres databases or using Heroku Streaming Data Connectors. During this time customers may receive notifications such as “Mutual TLS disabled on your Postgres add-on (DATABASE)” or “Mutual TLS has been disabled for DATABASE on
The Technology team is investigating the issue, including the impact of some recent deployment changes, as well as exploring multiple paths to resolution.
We’ll provide an update in 30 minutes, or when additional information becomes available.
Issue
Customers using MTLS to connect to Heroku Postgres databases or using Heroku Streaming Data Connectors are expected to face issues. Our engineers are actively working on this issue.
This is related to the incident: https://status.heroku.com/incidents/2422