Issues with Heroku API

Apps 3 hours, 9 minutes
Tools 3 hours, 9 minutes

Activity

  • Resolved

    At 16:27 UTC, on February 02, 2022, customers were out of impact. After monitoring the performance and validating the health checks Engineers have declared an all-clear. We apologize for any inconvenience this issue may have caused you or your organization. As always we perform a full root cause analysis including steps taken to prevent any recurrence.

    Posted 3 years ago, Feb 2, 2022 16:58 UTC

  • Monitoring

    Engineers restarted the Application Programming Interface (API) services to expedite the process of recovery. At 16:27 UTC, the majority of the customers should be out of disruption. However, customers can experience general and intermittent slow performance. We'll provide an update in 30 minutes, or sooner if additional information becomes available.

    Posted 3 years ago, Feb 2, 2022 16:50 UTC

  • Monitoring

    After the provisioning requests were scaled-down, our Engineers noted a continuous improvement in the performance levels. We have decided to monitor the progress for a brief duration as the sustained stability of services continues. We'll provide an update in 30 minutes, or sooner if additional information becomes available.

    Posted 3 years ago, Feb 2, 2022 16:22 UTC

  • Monitoring

    Engineers noted an increase in the number of provisioning requests that overloaded the platform. They have decided to manually scale down the requests to mitigate the impact. After the provisioning requests were scaled-down, services have started operating at normal performance levels. Engineers are still monitoring the performance before declaring an all-clear. We'll provide an update in 30 minutes, or sooner if additional information becomes available.

    Posted 3 years ago, Feb 2, 2022 15:52 UTC

  • Update

    Engineers are still working on multiple paths to resolve the issues and customers would still experience login issues while attempting to access dashboards, data.heroku.com, Command Line Interface (CLI), and other platform services, due to latency in Application Programming Interface (API) processing.

    Posted 3 years ago, Feb 2, 2022 15:21 UTC

  • Issue

    Engineers have identified the issue with the Heroku API and are actively working on a fix. We are currently seeing an impact on Heroku Dashboard, Build components, Heroku Scheduler, CLI usage, and Platform Authentication.

    Posted 3 years ago, Feb 2, 2022 14:50 UTC

  • Investigating

    Engineers are investigating potential issues with the Heroku API.

    Posted 3 years ago, Feb 2, 2022 13:49 UTC

Current status