Resolved
After investigation, there appears to be a valid workaround for this issue.
If you're still experiencing issues, please open a support ticket for further investigation.
Issue
Engineers are investigating latency issues with the Heroku dashboard starting around 13:44UTC Jan 5th.
Some downstream services are timing out. Several customers report that switching DNS or VPN seems to resolve the issue.