Some Records Not Being Synced By Heroku Connect

Data 10 hours, 16 minutes
Tools 12 hours, 33 minutes

Follow-up Report

Activity

  • Resolved

    The remediation process for the regions Virginia, Virginia-3, Dublin, Frankfurt, and Tokyo is completed.

    The remediation is ongoing for some instances and we are in direct communication for those affected.

    This issue is resolved.

    Posted 3 years ago, Oct 22, 2021 18:30 UTC

  • Update

    The remediation process for the following regions is in progress.

    Regions

    Virginia Virginia-3 Dublin Frankfurt Tokyo

    The next update will be either after six hours or upon the completion of the remediation process itself.

    Posted 3 years ago, Oct 22, 2021 14:53 UTC

  • Update

    We continue to move through the remediation process for the following regions and more connections should begin to see un-synced records restored.

    Regions

    • Virginia
    • Virginia-3
    • Dublin
    • Frankfurt
    • Tokyo

    The next update will be either after six hours or upon the completion of the remediation process itself.

    Posted 3 years ago, Oct 22, 2021 08:14 UTC

  • Update

    The remediation process for the Oregon region was completed. We are moving through the remediation process for other regions and more connections should begin to see un-synced records restored.

    The next update will be either after two hours or upon the completion of the remediation process itself.

    Posted 3 years ago, Oct 22, 2021 05:14 UTC

  • Update

    We continue to work on the remediation process for other regions.

    The next update will be either after two hours or upon the completion of the remediation process itself.

    Posted 3 years ago, Oct 22, 2021 03:13 UTC

  • Update

    The remediation process for the Sydney, 2-Dublin, and 2-Virginia regions was completed. We are moving through the remediation process for other regions and more connections should begin to see un-synced records restored.

    The next update will be either after two hours or upon the completion of the remediation process itself.

    Posted 3 years ago, Oct 22, 2021 01:18 UTC

  • Update

    As we move through the remediation process, some instances should begin to see missing records restored.

    This process will likely take multiple hours. As such, the next update we post will be posted either after two hours or upon the completion of the remediation process itself.

    Posted 3 years ago, Oct 21, 2021 23:10 UTC

  • Update

    We have identified all affected instances and are employing mitigation measures to correctively sync any un-synced records.

    Posted 3 years ago, Oct 21, 2021 21:23 UTC

  • Issue

    We noticed that a few changes to records in Salesforce were not properly synced by Heroku Connect to the respective Heroku Postgres databases. We are working to identify all of the impacted connections and prompt the syncing of this data.

    Posted 3 years ago, Oct 21, 2021 19:41 UTC

Current status