Declined credit card billing in India

Tools 23 hours, 34 minutes

Activity

  • Resolved

    We are working with our payment processor to resolve this issue for impacted customers. If you receive a suspension notice please reach out to us via a support ticket, and we will work with you to have the account remain active while this payment issue is resolved.

    Posted 3 years ago, Oct 13, 2021 16:48 UTC

  • Issue

    Engineers are aware of declined credit card payments by customers in India. They are working on a fix and provide updates as soon as they become available.

    Posted 3 years ago, Oct 12, 2021 17:13 UTC

Current status