Resolved
This incident has been resolved.
Update
Approximately 75% of affected apps have had mitigation applied. Engineering is continuing to work on the list of affected apps.
Issue
Starting on Thursday, August 13th, we received reports of customers receiving H10 errors despite their app's web dyno(s) running and receiving other requests. Continued reports since then revealed that a number of customers whose apps are being migrated began encountering H10 errors as soon as a single web dyno was migrated.
We are unable to provide a specific start time of impact because migrations are a progressive process, and the outage for a given app is dependent on when their dynos restarted for any reason (daily cycle, manual restart, scale, deployment, etc.).
Detail of the migration taking place has been previously emailed to customers and is described at https://devcenter.heroku.com/changelog-items/2151 . Engineering is actively working to resolve affected apps based off logs of recent migrations.