Increased errors from Heroku Postgres Connection Pooling

Data 3 hours, 9 minutes

Activity

  • Resolved

    This issue has been resolved.

    Posted 4 years ago, May 10, 2021 21:51 UTC

  • Monitoring

    The engineers triggered a reload of PgBouncer for customers of Heroku Postgres with Connection Pooling. Affected Heroku Postgres databases should no longer be reporting the errors.

    Posted 4 years ago, May 10, 2021 21:35 UTC

  • Update

    The engineers have deployed a fix.

    Posted 4 years ago, May 10, 2021 20:33 UTC

  • Retroactive

    Heroku Postgres with Connection Pooling enabled may show increased number of errors like:

    PG::TRSerializationFailure: ERROR: could not serialize access due to concurrent update
    

    Posted 4 years ago, May 10, 2021 18:42 UTC

Current status