Resolved
Engineers have implemented a fix, and we have observed emails beginning to be delivered again. Invoices will be resent to the affected team accounts.
This incident is resolved. If you have any invoice related queries, please open a support ticket.
Issue
From March 19th, Invoice related emails have not been delivered to credit card customers for at least the past 30 days. Engineers are currently looking into the issue, and we will update when we have more information.