HTTP and Git Connectivity Problems

Apps 27 hours, 14 minutes
Data 27 hours, 14 minutes
Tools 27 hours, 14 minutes

Follow-up Report

Activity

  • Resolved

    We have successfully mitigated the ongoing DDoS attack. All app operations are fully restored to all applications.

    Posted 14 years ago, May 17, 2011 19:12 UTC

  • Update

    All tools operation including git and api usage is now fully restored.

    Customers with properly configured DNS pointing to proxy.heroku.com should now have full app operations restored. Apps should ensure that their hostname is a CNAME record pointing to proxy.heroku.com. Root domains should continue to use A records. You can test if your hostmame is setup correctly by running:

    $ host www.heroku.com
    www.heroku.com is an alias for proxy.heroku.com.
    
    $ host heroku.com
    heroku.com has address 50.19.85.132
    ...
    

    See the docs for full information on DNS setup.

    Posted 14 years ago, May 17, 2011 18:42 UTC

  • Update

    We are still experiencing intermittent connectivity issues for HTTP and Git traffic. These issues are still isolated to applications that have a root domain pointed to Heroku via static IP addresses.

    We're continuing to work with our network provider to mitigate these availability issues.

    Posted 14 years ago, May 17, 2011 15:06 UTC

  • Update

    We're currently experiencing connectivity issues for both HTTP and Git traffic. The issues should be isolated only to applications that have a root domain pointed to Heroku via static IP addresses. Subdomains pointed to proxy.heroku.com, Hostname SSL setups, and IP SSL setups are all functioning normally.

    We're working closely with our network service provider to mitigate availability issues stemming from what we believe to be a DDoS attack. The current attack protection procedures have reduced the effects of this attack to intermittent issues.

    While we do not currently have an ETA for full resolution, connection error rates have fallen to very low levels. Our current plan is to leave the DDoS mitigation rules in place overnight. We will continue to monitor the situation and will resolve these intermittent issues as quickly as possible.

    Posted 14 years ago, May 16, 2011 20:03 UTC

  • Update

    We continue to work with our provider but have no new information to report at this time.

    Posted 14 years ago, May 16, 2011 17:10 UTC

  • Update

    We don't have any additional information to report at this time. The errors appear to be coming in at a low rate, and we're continuing to work with our provider to resolve them entirely. We will provide additional updates as information is available. Our next planned update will be at 10:00 Pacific Time.

    Posted 14 years ago, May 16, 2011 16:31 UTC

  • Issue

    We are currently working with our network provider to mitigate network problems that are affecting a small number of our front-end web servers. This is primarily affecting those customers that are pointing a root domain to Heroku via static IP addresses.

    Posted 14 years ago, May 16, 2011 15:57 UTC

Current status