Resolved
Dedicated database provisioning is back online. We will follow-up with more information after we've assessed the situation.
Update
We are still working on the issue, we'll post an update when we have more information. Running dedicated databases are not affected. Thank you for your patience.
Issue
Dedicated database provisioning is offline. Existing dedicated database servers are unaffected. We are working to resolve the issue.