Resolved
Github service appears to be fully restored, and we're not seeing any further errors related to add-on installations.
Issue
We're currently experiencing limited installation issues for add-ons due to the current github service interruption. Github is posting updates on the issue via Twitter: http://twitter.com/github.