Resolved
Dedicated database provisioning is back online.
Posted 14 years ago, Mar 7, 2011 05:08 UTC
Issue
We are currently investigating an issue affecting the provisioning of new dedicated databases.
Posted 14 years ago, Mar 7, 2011 04:34 UTC