Resolved
This problem has been resolved and all applications should be functioning normally.
Issue
We're seeing slow performance and timeouts for some customers using the IP based SSL addon. We are aware of the problem and working to resolve it as quickly as possible.