Resolved
Network latency has returned to normal.
Posted 14 years ago, Dec 16, 2010 22:16 UTC
Issue
We are seeing intermittent timeouts and connection errors. We are currently investigating.
Posted 14 years ago, Dec 16, 2010 21:56 UTC